Inne

Nietypowy wykres w Excelu – uaktualnienie wpisu

Uaktualniłem dzisiaj mój wpis opisujący sposób wykonania nietypowego wykresu w Excelu. Nowy (uaktualniony) wpis jest lepszy od starego ponieważ: dodałem kilka animacji (zamiast statycznych obrazków), dodałem nową formułę sterującą formatowaniem warunkowym, która  umożliwia wybór kierunku „zapełniania się” wykresu. Do tej pory rozpoczynaliśmy w lewym dolnym rogu, teraz możemy „zaszaleć” i rozpocząć w rogu prawym, wgrałem […]

Czytaj cały wpis →

Jak wylosować niepowtarzające się liczby z określonego zakresu

W kolumnie (na potrzeby przykładu załóżmy, że będzie to zakres $B$2:$B$11) mamy wpisane niepowtarzające się liczby. Pytanie na dzisiaj brzmi: w jaki sposób wylosować z takiego zakresu 5 niepowtarzających się liczb i umieścić je w jednym wierszu, oddzielone od siebie myślnikiem. Całość wygląda mniej więcej tak: Poniżej przedstawiam moją propozycję rozwiązania problemu. Skorzystamy z kolumny […]

Czytaj cały wpis →

Kilka wierszy w komórce Excela – dodatkowe przemyślenia

Kilka dni temu pisałem o usuwaniu z komórki Excela znaków podziału linii, które wstawiamy sobie od czasu do czasu przy pomocy kombinacji klawiszy ALT+ENTER. W rezultacie, mamy oczywiście komórkę, w której znajduje się ciąg tekstowy podzielony na kilka wierszy. Dzisiaj napiszę o tym w jaki sposób można wybrać i wyświetlić tylko jeden, wskazany wiersz z […]

Czytaj cały wpis →

Problem kilku wierszy w komórce Excela (Alt+Enter)

Pracując z Excelem, od czasu do czasu, dzielisz prawdopodobnie jeden długi ciąg tekstowy, znajdujący sie w komórce Excela, na kilka wierszy. Nowy wiersz rozpoczynasz wtedy przy pomocy kombinacji klawiszy ALT+ENTER. Krótki filmik poniżej pokazuje dokładnie o czym piszę. Oczywiście w przypadku  „kilku wierszy” do nowej linii przechodziłem uzywając wspomnianej kombinacji Alt+Enter. Zdarzają sie jednak sytuacje […]

Czytaj cały wpis →

Excel i wybieranie dat

Dzisiaj o tym, w jaki sposób zrobić bardzo prostą „wybieraczkę” dat w Excelu.  W zasadzie cały problem sprowadza sie do tego, aby w zależności od wybranego miesiąca i roku ( dla lat przestępnych luty bedzie miał 29 dni, dla pozostałych 28)  wyświetlić  odpowiednią liczbę dni.  Dla miesiąca stycznia lista powinna zawierać 31 dni, dla czerwca […]

Czytaj cały wpis →

Wykres „piramida wieku”

Dzisiaj o jednej z metod przygotowania w Excelu wykresu zwanego piramidą wieku. Zaczynamy od danych źródłowych. W moim przykładzie wyglądają one tak: Na swoje potrzeby musiałem te dane wzbogacić o dwie dodatkowe kolumny. Odpowiednia formuła dla kolumny dodatkowej 2 to, jak łatwo zgadniesz: =JEŻELI(E3>C3;C3;E3) Wstawione przeze mnie kolumny będą stanowić źródło danych dla dodatkowych serii […]

Czytaj cały wpis →

Kryteria filtrowania poza nagłówkiem tabeli

Pytanie jakie otrzymałem od Małgorzaty: „Posiadam tabelę z następującymi kolumnami: nr dokumentu, branża, typ dokumentu, adresat, data, opis pisma. Tabela ma być filtrowana wg branży i typu dokumentu. Czy dałoby się zrobić tak, żeby warunki filtrowania znajdowały się powyżej tabeli, a nie bezpośrednio w nagłówku tabeli?” Problem (w moim odczuciu) jest głównie estetyczny, niezależnie bowiem […]

Czytaj cały wpis →