Filtrowanie liczb i znaki wildcards

by Marcin

W kolumnie mamy serię 9 cyfrowych liczb. Mniej więcej tak jak na rysunku poniżej.

Filtrowanie liczb z użycien znaków wildcards. Lista liczba

Zadanie polega na tym, aby odfiltrować tylko te pasujące do wzorca 5*****2** lub 5*****3**. Innymi słowy, każda przefiltrowana liczba musi zaczynać się cyfrą 5, a na siódmej pozycji musi znaleźć się cyfra 2 lub 3.

Skoro potrzebujemy przefiltrować to oczywiście skorzystamy z dostępnych w Excelu … narzędzi filtrowania (Autofiltr lub Filtr zaawansowany). „Wzorzec” ustawimy przy pomocy znaków wildcards. W naszym przypadku wygląda to tak:

5?????2??   lub  tak: 5?????3??

Zastosujmy od razu Autofiltr. Ku naszemu zdziwieniu okazuje się, że filtr nie działa tak jak powinien. Na czym polega problem ?

Sprowadza się on w zasadzie do jednego. Znaki wildcards, z sobie tylko znanych powodów, nie chcą działać z liczbami. Pierwsza myśl jest więc taka, aby po prostu zamienić format komórek na tekstowy. Okazuje się, że i to nie pomaga. Filtr wciąż nie działa tak jak powinien.

Na pomoc przychodzi funkcja TEXT (przy pomocy, której zamienimy liczby na tekst) oraz kolumna pomocnicza.  Jak widzisz na rysunku poniżej, w kolumnie pomocniczej znajduje się formuła:

=TEXT(B5;”@”)

Filtrowanie liczb z uzyciem znaków wildcarts. Kolumna pomocnicza

Nową kolumnę możesz teraz możesz przefiltrować otrzymujac oczekiwany rezultat. Sprawdźmy to sobie.  Zaznacz zakres z danymi, zastosuj Autofiltr, następnie jako kryterium sortowania wybierz „Niestandardowe” i wprowadź następujące dane:

Filtrowanie liczb z użyciem znaków wildcards. Ustawienia.

W rezultacie na przefiltrowanej liście znajdą się tylko wartości odpowiadające naszemu wzorcowi.

Filtrowanie liczb z użyciem znaków wildcards. Rezultat końcowy.

Pozdrawiam wszystkich serdecznie.

Marcin

{ 6 comments… read them below or add one }

marian45

chyba powinno być: „lub równa się 5?????3??

adam

Witam,

Mam problem z excelem. Mam tabelę – dla uproszczenia w kolumnie 1. są daty w formacie rrrr-mm-dd w kolumnie 2. kwoty. Chciałbym napisać formułę, która sumuje kwoty np. z lutego 2009.
Wstawiam ją w drugiej tabeli
=SUMA.WARUNKÓW(dane!B:B;dane!A:A;”>=2009-02-01″;dane!A:A;”=B19″;dane!A:A;”<=B20″)

wychodzi 0

Czy ktoś wie o co chodzi?

tutusem

Nie miejsce na to adam, ale spróbuj tego:
=SUMA.WARUNKÓW(B:B;A:A;”>=2009-02-01″;A:A;”<2009-03-01″)

znik

adam, błąd.
masz „=B19”, i będzie ci szukał komórki z wartością =B19 .
jak już, musi być tam gołe B19 i wtedy jest równe, jeśli chcesz użyć operatora,
robisz złączenie tekstów, np. „=”&B19 albo „<=”&B19 .
oczywiście możesz skorzystać z funkcji złącz.teksty 🙂

arielp

witam,
mam problem ze wstawieniem dwoch formul w excelu. moze tutaj znajdę pomoc, jak to zrobic? wrzucilem na sendspace.pl plik z juz wykonanymi zadaniami i z poleceniami, ktorych nie potrafie wykonac. z gory dziekuje za pomoc!
http://www.sendspace.pl/file/gCCEVFbR/

Marcin

Witam,

Niejako z zasady nie rozwiazuje „prac domowych”. Polecam poczytac o
formulach w excelu i zadania wykonac samemu. Ewentualnie ich nie
wykonywac i honorowo pogodzic sie z ocena niedostateczna (lub inna
mnie niz zadowalajaca) 🙂

Powodzenia,

Marcin

Leave a Comment

Previous post:

Next post: